Lonely Integer - Hacker Rank Program

Problem Statement
There are N integers in an array A. All but one integer occur in pairs. Your task is to find the number that occurs only once.
Input Format
The first line of the input contains an integer N, indicating the number of integers. The next line contains N space-separated integers that form the array A.
Constraints
1N<100
N % 2=1 (N is an odd number)
0A[i]100,i[1,N]
Output Format
Output S, the number that occurs only once.
Sample Input:1
1
1
Sample Output:1
1
Sample Input:2
3
1 1 2
Sample Output:2
2
Sample Input:3
5
0 0 1 2 1
Sample Output:3
2
Explanation
In the first input, we see only one element (1) and that element is the answer.
In the second input, we see three elements; 1 occurs at two places and 2 only once. Thus, the answer is 2.
In the third input, we see five elements. 1 and 0 occur twice. The element that occurs only once is 2.


MY SOLUTION:

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <assert.h>
int main()
    {
    int n;
    scanf("%d",&n);
    int hash[100]={0},i,x,result=0;
    for(i=0;i<n;i++)
    {
        scanf("%d",&x);
        hash[x]++;
    }
    for(i=0;i<100;i++)
    {
        if(hash[i]==1)
            printf("%d",i);
    }
    return 0;
}

Convert resultset object to list of map

Convert the resultset object to list of map In some cases, while we doing API automation, we need to fetch the value from the DB and hav...