Flipping bits - Hacker Rank Program

Problem Statement
You will be given a list of 32 bits unsigned integers. You are required to output the list of the unsigned integers you get by flipping bits in its binary representation (i.e. unset bits must be set, and set bits must be unset).
Input Format
The first line of the input contains the list size T, which is followed by T lines, each line having an integer from the list.
Constraints
1T100
0integer<232
Output Format
Output one line per element from the list with the requested result.
Sample Input
3 
2147483647 
1 
0
Sample Output
2147483648 
4294967294 
4294967295
Explanation
Take 1 for example, as unsigned 32-bits is 00000000000000000000000000000001 and doing the flipping we get 11111111111111111111111111111110 which in turn is 4294967294.

MY SOLUTION:


#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>

int main() {

    int t;
    scanf("%d",&t);
    while(t--)
        {
        int value;
        scanf("%u",&value);
        printf("%u\n",value^(0xFFFFFFFF));
    }
    return 0;
}

Convert resultset object to list of map

Convert the resultset object to list of map In some cases, while we doing API automation, we need to fetch the value from the DB and hav...